View Full Version : Speakers Buzzing

03-16-2004, 03:10 PM
My computer speakers started to have a low volume buzz today. I never did anything to blow em. Is there a way to filter, or fix the problem? I already tried unplugging and replugging them in.

03-16-2004, 03:41 PM
Raise left hand. Extend forefinger. Insert forefinger in left ear. Repeat for right side. :lol:

Seriously, it sounds like you have developed mains hum. Assuming your speakers are powered, try unplugging them from your system but with power still applied to your speakers.

If possible, remove the signal lead from the rear of the speakers, otherwise remove it at the processor end but coil the wire up as far away from any power leads as possible.
If the noise persists then it is internal to the speakers. Possibly a dry solder joint. It then depends whether you think you can fix that sort of problem, and whether the speakers are worth it.

If the noise goes away, try putting the signal cable back where it was, but unplugged at the processor end. If the noise returns you are picking up noise through the cable - try moving mains leads as far away from the signal lead as possible. If necessary replace the lead with low attenuation cable. I've used this (http://www.maplin.co.uk/products/module.asp?CartID=040316143458372&moduleno=13307&Products=2) in the past, you should be able to get something similar where you are.

If the noise only returns when you plug back into the processor end, you've probably got a problem with your sound card. Assuming it isn't on the mobo try removing the card, clean the edge contacts (an ink eraser is ideal for this) and replace the card. If that doesn't cure it there's not much more you can do.

03-16-2004, 04:42 PM
Jeez that was long. He may be right though.
I say just uninstall your sound card drivers & reinstall them.

03-16-2004, 05:07 PM
double click the sound icon on your desktop, then find MIC, MONOBOOST (if u have that) and LINE IN. Mute them all, especially mic and mono boost if you have it. My old computer hums when I have them unmuted.

03-16-2004, 05:11 PM
Have you tried washing them?

I find I hum if I don't wash for a while. :lol: