Your Ad Here Your Ad Here
Results 1 to 5 of 5

Thread: Trouble With Sound In Freelancer

  1. #1
    I downloaded and installed Freelancer.iso, it worked great, EXCEPT that some of the sound randomly doesn't play. Now to me that would make sense if it was the same sound every time, since maybe a second disk with a whole set of sounds was never downloaded. Except, if I run through a mission a second time, sometimes the sounds that I missed will play while those that I heard in the last run won't play at all! Anyway you all seem to have no problem with Freelancer...am I missing some quick fix that everyone else has easily come across? I tried searching and looking around (both are particularly useless here) and couldn't find any mention of that problem. Hopefully someone has a fix or at least an explanation. Thanks.

  2. ** REGISTER to REMOVE This Ad On The Site!! **
    Your Ad Here Your Ad Here
  3. Games   -   #2
    What are your comp stats?

  4. Games   -   #3
    What are your comp stats?

  5. Games   -   #4
    Poster
    Join Date
    Mar 2003
    Location
    London, UK
    Posts
    599
    What are your comp stats?

  6. Games   -   #5
    Here are two fixes for the sound problem in Freelancer.
    First one is from the readme and the second one is from another forum.
    I found the second one to work best for me.


    =======================================================================
    If you hear missing game sounds throughout Freelancer then a different audio codec is probably being used rather than the one provided by Freelancer.

    Please follow these steps if some sounds and speech are still missing after installation.

    1. Uninstall any 3rd party codec pack or the Nimo Codec pack from your system.
    2. Uninstall Freelancer.
    3. Go to the following directory, C:\WINDOWS\system32 and delete the file "l3codeca.acm". If there happens to be another file named "l3codecp.acm", delete this too.
    4. If your system is Windows 98 or ME, open the system.ini file located in your system folder; C:\WINDOWS\SYSTEM. Delete ONLY the line that starts with "msacm.l3acm=". In the case of the Nimo codec pack, this will read "msacm.l3acm=l3codecp.acm"
    5. If your system is Windows 2000 or XP, open the system registry editor (regedit) from the RUN command window.
    6. Locate and delete the following key: \HKLM\SOFTWARE\Microsoft\
    WindowsNT\CurrentVersion\
    Drivers32\msacm.l3acm
    7. Load the Freelancer installation CD and locate the REDIST folder. Within the REDIST folder, double click on the file named “WMFADist.exe” and follow on-screen instructions.
    8. Install Freelancer.
    =======================================================================


    =======================================================================
    1. Open control panel
    2. go to Sound And AUdio Devices
    3. On Hardware Tab, in the list click on Audio Codecs
    4. Select "Fraunhoffer MPEG Layer ..." codec
    5. Click Remove
    6. Don't restart even if asked to
    7. Open WIndows Explorer
    8. In ..<WinDir>&#092;System32&#092; (or just the system folder, depends on your OS)
    folder delete/rename the files "l3codeca.acm" and "l3codecp.acm"
    9. Restart WIndows
    10. Download "wma8_redist.exe" and "wma9_redist.exe" from Internet location (listed below)
    11. Install both packages, first "8" then "9"
    12. Open Sound And Audio Devices in Control Panel again
    13. On Hardware Tab, in the list, doubleclick the now available
    "Fraunhofer..." codec
    14. In the codec properties, set priority to "1".
    Check the Fraunhofer IIS MPEG Layer-3 Codec&#39;s properties
    and make sure that the "use this codec" is checked&#33;
    15. Start Freelancer, New Game: Sound is working fine now.

    h**p://sivut.koti.soon.fi/poiko/wma8_redist.exe
    h**p://sivut.koti.soon.fi/poiko/wma9_redist.exe
    =======================================================================


    I found that not installing the wma9_redist.exe worked best but go on and install both first and see if it worked then start over and just install wma8_redist.exe if you can&#39;t get it to work.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •