Your Ad Here Your Ad Here
Results 1 to 4 of 4

Thread: Mouse

  1. #1
    I don't know what's going on! My mouse is a Logitech cordless optical mouse, and it has been messing up on me lately. when browsing or doing anything, it will just stop, kind of lag, it feels as if it was a really dirty wheel mouse. I replaced batteries in it, still no avail. Tried reconnecting it as well, also reinstalling the software that came with it. In the device manager, it says everything is fine and all my drivers are installed correctly, anyone know the problem here!?!
    Here is my mouse

    Q6600 @ 3.42Ghz | Gigabyte EP35-DS3R | EVGA 8800GT 721/1802/2006 w/ Accelero S1 | 4gb Crucial DDR2 @ 760mhz | 750gb Hitachi 7k1000 | Corsair 520HX | 2 x Samsung SyncMaster T240 24" | Windows 7 Ultimate

  2. ** REGISTER to REMOVE This Ad On The Site!! **
    Your Ad Here Your Ad Here
  3. Software & Hardware   -   #2
    bigdawgfoxx's Avatar Big Dawg
    Join Date
    Apr 2003
    I havnt heard good things about wireless mice at all...but Ive never heard of that so I duno.
    [SIZE=1]AMD 4200 X2 @ 2.65Ghz, ASRock 939-VSTA
    1.75GB PC3200, 2 X 160GB Seagate w/ 8MB Buffer
    HIS Radeon X800 Pro, Antec Super Lanboy Aluminum

  4. Software & Hardware   -   #3
    Saw this once before, I ran adaware on the computer and found that there was a lot of it running in the background bogging down everything, try running that, check for viruses too while you are at it. Hope that helps you.

  5. Software & Hardware   -   #4
    Skillian's Avatar T H F C f a n BT Rep: +1
    Join Date
    Dec 2002
    Also check the position of your receiver, and that's it's not to near to magnetic or transmitting equipment.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts