Your Ad Here Your Ad Here
Results 1 to 8 of 8

Thread: PSP v2.0 is here

  1. #1
    Yep, itís here: weíre getting reports from all over that the North American version of the PSPís new 2.0 firmware upgrade has arrived. At least if youíre using Network Update, that is. The upgrade is still not available for download via Sonyís PlayStation Portable site, but odds are itíll show up there sometime later today.
    [PHPIMG]http://img.engadget.com/common/images/2475140848426705.jpg?0.602836244507777[/PHPIMG]
    http://www.engadget.com/entry/1234000650055745/
    Last edited by RealitY; 08-24-2005 at 08:04 AM.

  2. Games   -   #2
    Spicker's Avatar AKA jaigandhi5 BT Rep: +7BT Rep +7
    Join Date
    Dec 2002
    Location
    Canada
    Posts
    3,484
    dont update if u want to play backups and want homebrew...

    My Blog
    I'm still here.

  3. Games   -   #3

  4. Games   -   #4
    Retired
    Join Date
    Feb 2003
    Posts
    14,058
    Quote Originally Posted by Spicker
    dont update if u want to play backups and want homebrew...
    if you do not update you cannot play new games.

  5. Games   -   #5
    suprafreak6's Avatar Suprafreak6 is Back!
    Join Date
    Apr 2005
    Location
    -=U.S.A=-
    Posts
    2,450
    there are loaders that bypass the check, i think....

  6. Games   -   #6
    Spicker's Avatar AKA jaigandhi5 BT Rep: +7BT Rep +7
    Join Date
    Dec 2002
    Location
    Canada
    Posts
    3,484
    Quote Originally Posted by {I}{K}{E}
    Quote Originally Posted by Spicker
    dont update if u want to play backups and want homebrew...
    if you do not update you cannot play new games.
    there is no game atm that requires u to update to 2.0 and when there is one im sure u can use a loader or something to bypass it

    homebrews all the way!

    My Blog
    I'm still here.

  7. Games   -   #7
    pspupdates.com all the way they explain everything about homebrew
    Systems Specs
    -----------------------------------
    O/S: Windows Xp Service Pack 2
    Processor: Intel Pentium 4
    Speed: 2.6 ghz
    Graphics: Nvidia Geforce 6800 128MB DDR SDRAM
    Ram: 1Gig of ram
    Comp Model: Hp Pavilion a250n
    -----------------------------------

  8. Games   -   #8
    Spicker's Avatar AKA jaigandhi5 BT Rep: +7BT Rep +7
    Join Date
    Dec 2002
    Location
    Canada
    Posts
    3,484
    Just take a look at this:
    This was just released seconds ago:

    Yoshihiro, of WAB, has released a PSP Version Changer:

    What this program does, is trick games that require firmware version 1.52 to run on your 1.50 PSP.

    The implications are huge. You won't have to run the updates that are required by new UMD games, simply load this EBOOT, and it makes the system run the game anyways.

    As an extra benefit, if you try to run the 1.52 updater on your 1.5 PSP using this EBOOT, it won't update. Think of it as a sort of 1.5 firmware update protector. No more accidently flashing your firmware.

    From the .nfo file:

    Yoshihiro and WAB are proud to bring you The First Firmware Trickz for Gamez that need Firmware 1.52 to run on your PSP and Cant Run UPDATER 1.52. The System think it's a PSP v1.52 even if its a v1.5.

    Good job Yoshihiro and WAB. Keep up the good work!

    Download this file here
    Forum Topic here

    Cheers
    FROM: psphacks.net
    Last edited by Spicker; 08-25-2005 at 02:43 PM.

    My Blog
    I'm still here.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •