Your Ad Here Your Ad Here
Results 1 to 4 of 4

Thread: know abt installing car subs? Help me here!

  1. #1
    sameer0807's Avatar I aIn'T nO sErIoUs
    Join Date
    Feb 2004
    Location
    - = C.a.N.a.D.A = -
    Age
    30
    Posts
    961
    Hey,

    I have just finished installing system in my car. The amp powers up, but the subs are not working. I have checked the connections and all, cant find any loose wire or any thing like that.

    Remote wire is good.
    Ground wire is also connected good.

    Does any one know of a possible reason why the amp is working but not the subs?

    I have Pioneer 800 watts amp (Brand new, bought it today)
    2 12" JBL subs
    JVC AR3000 deck (brand new, bought it today)
    Civic 03

    and really thick wires ( i think its 1000 watts)

    Please help!
    Last edited by sameer0807; 09-07-2005 at 01:36 AM.

    "I'll be here... I'll be 'waiting'...here... I'll be waiting... for you ... so... If you come here... You'll find me. I promise..."

  2. Software & Hardware   -   #2
    muchspl3's Avatar muchspl3 > muchspl2
    Join Date
    Nov 2003
    Location
    Location Location
    Posts
    1,824
    do you have a 9volt battery?

    pull the wires to the sub and tap the +/- on the 9volt
    it should pop if it dies you know its not the sub, if it doesn't you know you have blown the VC

    you just have to go down the list after you know one part is working, process of elimination
    `anyone from Argentina on this board?

    I need your help and if you can help me pM me

  3. Software & Hardware   -   #3
    Duffman's Avatar Poster
    Join Date
    Jul 2003
    Age
    29
    Posts
    1,130
    Take the 9v battery and touch it to your tounge, if it works you get a tiny shock.
    ...

  4. Software & Hardware   -   #4
    sameer0807's Avatar I aIn'T nO sErIoUs
    Join Date
    Feb 2004
    Location
    - = C.a.N.a.D.A = -
    Age
    30
    Posts
    961
    Quote Originally Posted by muchspl3
    do you have a 9volt battery?

    pull the wires to the sub and tap the +/- on the 9volt
    it should pop if it dies you know its not the sub, if it doesn't you know you have blown the VC

    you just have to go down the list after you know one part is working, process of elimination
    Ok I'm kinda confused....I'm not quite sure what you talking abt here.....

    BTW my subs have some sort of distorted bass (very little bass, I could feel it when i touch the sub)....does this could be because of a poor connection with the car battery or something?

    Or does this mean my subs are f****d?

    thanks for ur time,
    Last edited by sameer0807; 09-07-2005 at 04:50 AM.

    "I'll be here... I'll be 'waiting'...here... I'll be waiting... for you ... so... If you come here... You'll find me. I promise..."

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •