Your Ad Here Your Ad Here
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: might get a psp

  1. #1
    Poster
    Join Date
    Jul 2003
    Location
    london baby!!
    Posts
    369
    right i am really wanting one of these but i`ve been reading that u need one with firmware 1.5 to play downloaded (homebrew??) games, but then i`ve read games like ghost in the shell and GTA need 2.0 to use all the option`s and stuff, could some please give me info or where to look, cheers

  2. Games   -   #2
    mike45450's Avatar =_=_=
    Join Date
    Feb 2003
    Location
    England
    Age
    28
    Posts
    511
    2.0 has been cracked and can play about 60% of all current homebrew apparently. I have 2.0 with just a snes emu, mainly coz i've still got a 32MB stick, but i can't really find any decent homebrews worth putting on.

    The web browser on 2.0 is soooo much better than the 1.5 alternatives. You don't realise how good it is till you have to use another one.


  3. Games   -   #3
    Poster
    Join Date
    Jul 2003
    Location
    london baby!!
    Posts
    369
    right the psp i was going to get is jap with the 2.0 i think and if i want he can 1.5 it, it thought i needed 1.5 to play homebrew, but is this a new cracked 2.0 or what, sorry i am well new to all this

  4. Games   -   #4
    Spicker's Avatar AKA jaigandhi5 BT Rep: +7BT Rep +7
    Join Date
    Dec 2002
    Location
    Canada
    Posts
    3,484
    There's a downgrader that lets u downgrade from 2.0 to 1.50.

    My Blog
    I'm still here.

  5. Games   -   #5
    silent h3ro's Avatar Poster BT Rep: +9BT Rep +9
    Join Date
    Nov 2003
    Location
    Detroit
    Age
    27
    Posts
    4,461
    Quote Originally Posted by mike45450
    2.0 has been cracked and can play about 60% of all current homebrew apparently. I have 2.0 with just a snes emu, mainly coz i've still got a 32MB stick, but i can't really find any decent homebrews worth putting on.

    The web browser on 2.0 is soooo much better than the 1.5 alternatives. You don't realise how good it is till you have to use another one.
    Where can u get the 2.0 cracked. 2.0 is sooo much better than 1.5, mainly because of the wallpaper changer and def the browser but it's really slow for me.

  6. Games   -   #6
    Rip The Jacker's Avatar Retired
    Join Date
    Nov 2002
    Location
    Los Angeles, CA
    Age
    31
    Posts
    6,435
    Quote Originally Posted by hondarvf400
    right i am really wanting one of these but i`ve been reading that u need one with firmware 1.5 to play downloaded (homebrew??) games, but then i`ve read games like ghost in the shell and GTA need 2.0 to use all the option`s and stuff, could some please give me info or where to look, cheers
    You don't need a 1.5 PSP, but it's better to have a 1.5 PSP if you really want homebrew. 2.0 PSP's can run some homebrew... It is possible to downgrade from 2.0 to 1.5 easily...

    Some places to look around for information:
    http://www.pspforums.com/forums/index.php
    http://forums.qj.net/forumdisplay.php?f=48

    Right now I have a 1.5 PSP with:
    -SNES emulator
    -Sega Genesis emulator
    -GBC emulator
    -NeoGeo CD emulator (Metal Slug rules!)
    -Doom 1 and 2 for PSP
    -UMD emulator with Twisted Metal and Marvel Nemesis on the memory stick
    -Dead to Rights, installed onto the memory stick
    -Puzzle Bobble, installed onto the memory stick
    -Coded Arms, installed onto the memory stick
    -Polygon (clone of Bejeweled)
    -FileAssistant++
    -SXT's Version Changer (tricks your PSP into thinking it's a 2.0 or 7.5 PSP)

    [/Bragging]


  7. Games   -   #7
    Poster
    Join Date
    Jul 2003
    Location
    london baby!!
    Posts
    369
    right ripper thanks for that, but i am getting a jap one and u will downgrade it for me, i`ve been reading about GTA being 1.6GB so i`ll buy that one, but i think it need`s firmwear 2.0 to play it so i can go up and down with the firmwear as need easy, like when i am at work?????

    i know its all quite new so will they crack the newest firmwear so that it will play homebrew, also how do the emu`s play?????, they sound wicked!!!!

  8. Games   -   #8
    mike45450's Avatar =_=_=
    Join Date
    Feb 2003
    Location
    England
    Age
    28
    Posts
    511
    Quote Originally Posted by Gam3Guy
    Where can u get the 2.0 cracked. 2.0 is sooo much better than 1.5, mainly because of the wallpaper changer and def the browser but it's really slow for me.
    http://www.fanjita.org/psp.html

    At the bottom, there's also a list of compatible homebrews for 2.0 on that site too.


  9. Games   -   #9
    Poster
    Join Date
    Jul 2003
    Location
    london baby!!
    Posts
    369
    one more for you all, which one the usa or the jap one comes with sharpe screen and are they better????

  10. Games   -   #10
    Spicker's Avatar AKA jaigandhi5 BT Rep: +7BT Rep +7
    Join Date
    Dec 2002
    Location
    Canada
    Posts
    3,484
    Quote Originally Posted by hondarvf400
    one more for you all, which one the usa or the jap one comes with sharpe screen and are they better????
    Jap-Sharp.

    My Blog
    I'm still here.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •