Your Ad Here Your Ad Here
Results 1 to 9 of 9

Thread: Civ 4

  1. #1
    I have 'aquired' Civ 4 but cant get it to load it keeps telling me to insert correct cvrom, anyone help? (tell me of a no cd crack?) Sorry if this is the wrong place

  2. Software & Hardware   -   #2
    Virtualbody1234's Avatar Forum Star BT Rep: +2
    Join Date
    Oct 2003
    Location
    Canada
    Posts
    11,497
    Did you check if there is an .nfo file? Open it with Notepad.

  3. Software & Hardware   -   #3
    kazaa2002's Avatar lost
    Join Date
    Dec 2003
    Location
    near oz
    Posts
    234
    Quote Originally Posted by quortoth
    I have 'aquired' Civ 4 but cant get it to load it keeps telling me to insert correct cvrom, anyone help? (tell me of a no cd crack?) Sorry if this is the wrong place
    Hi Quortoth

    there is a problem with the retail version and a 256mb ati card
    if this what you have...(unpacking problem)
    you need to have the latest ati drivers
    latest version directoryx (comes on this cd)
    and here is a link, follow the instructions Apolyton Civilization Forums > Civilization IV > Civ4-Help > New fix for the renderer error
    download the fix and install
    and then reboot
    no problem with nvidea cards
    I just had to do this procedure for a friend
    who had problem with loading civ 4 on his new pc.
    if this is not the case tell vb what the nfo says.
    or if you can...give us a little more info.
    Last edited by kazaa2002; 11-07-2005 at 07:29 PM. Reason: adding working link

    it is the small things that usually drive us mad

  4. Software & Hardware   -   #4
    I found I got that error unless I used alcohol 120 combined with Anti-Blaxx 1.17. Set the protection to securerom 7, delete entries and restore after the game exits. Just make sure to run the backup option before (in case you lose power or something before you exit the game)
    I meditate diligently every morning. The subject is Life and Love. I quit after three seconds. - Vash

  5. Software & Hardware   -   #5
    ok, i loaded it with Daemon Tools conbind with something called sd4hide, anyway, it know loads but... you dont see peoples faces, just teeth and hair and you dont see any landscape, its all black even when you move your units into new areas, the opponent (such as lions etc...) appear and other villages appear but you cant see anything else. i had this problem with Area 51 too and i ended up throwing it. Any suggestions on how i can fix this (without throwing it)?

    Thanks So Much for you help already people and keep up the good work

  6. Software & Hardware   -   #6
    Virtualbody1234's Avatar Forum Star BT Rep: +2
    Join Date
    Oct 2003
    Location
    Canada
    Posts
    11,497
    Quote Originally Posted by quortoth
    ok, i loaded it with Daemon Tools conbind with something called sd4hide, anyway, it know loads but... you dont see peoples faces, just teeth and hair and you dont see any landscape, its all black even when you move your units into new areas, the opponent (such as lions etc...) appear and other villages appear but you cant see anything else. i had this problem with Area 51 too and i ended up throwing it. Any suggestions on how i can fix this (without throwing it)?

    Thanks So Much for you help already people and keep up the good work
    Use another graphics driver.

  7. Software & Hardware   -   #7
    i think that i might have it sorted, ill play it later and let people know

    Thanks so much people for all your help

  8. Software & Hardware   -   #8
    orcutt989's Avatar Blargh
    Join Date
    Dec 2003
    Location
    States
    Posts
    2,227
    You could just use Daemon tools to mount the DVD, then use this small EXE called sd4hide.exe, which hides all your emulation entrees, it must be turned on during playing, and it will work. Works for me and many others.

  9. Software & Hardware   -   #9
    yer, ive done that, im still having the same problem, ive been told to try getting a new graphics card as it may be that anyone know any cheap place to get one?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •