Your Ad Here Your Ad Here
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: GTA : LCS Running on 1.50 Firmware!!!!!!

  1. #1
    Spicker's Avatar AKA jaigandhi5 BT Rep: +7BT Rep +7
    Join Date
    Dec 2002
    Location
    Canada
    Posts
    3,484
    Everything was working out peachy for PSP Gamers, or so they thought as they started to enjoy the homebrew and their current PSP games off the same handheld earlier this year. Then Sony started releasing firmware updates. This update not only added a few nice features for video / web browsing but at the same time disabled the homebrew exploit, KXploit.

    This is where MPH comes in. When a PSP is upgraded to 2.0, Sony had temporarily prevented all previous forms of running homebrew on the PSP(hacks that ran via Kxploit), with the help of determined and noteworthy developers such as Groepaz and MPH, among others they succeeded in releasing a downgrader from PSP System Software version 2.0 to 1.5. Thus allowing PSP gamers to have full access to their PSP's again.

    Sony has been relentless and has been releasing more updates, 3 individual updates, in fact since the last time the PSP was blocked and then rehacked. Some updates are purely "preventative" ones. That "prevent a hacker from bricking your psp" (aka reblocking the ability to run homebrew.) While others actually serve a purpose, from the likes of adding Location Free connectivity to simple RSS feed integration.

    This latest update from MPH won't cease to amaze, as MPH announced that they have succeeded in launching Grand Theft Auto on his 1.50 version PSP. Loading GTA as a UMD or ISO for that matter was futile previously on 1.5 PSP's, since GTA requires files in the 2.0 library in order to function. This resulted in people needing to update to 2.0 in order to play GTA on their PSP or have another PSP with 2.0+ System Software. Needless to say this is a major step forward in fully unlocking the PSP so gamers may do whatever they wish with a handheld that they purchased for their enjoyment.

    In order to run this exploit you must have the following:
    - GTA:LCS official Game or ISO Backup (that you must create from your legally owned copy)
    - You will need umd emulator, umdgen and a tool called DecryptPRX which is no other than a modification of the psardump tool of psppet.

    Source: MPH

    My Blog
    I'm still here.

  2. Games   -   #2
    Guyver's Avatar FORUM STONER
    Join Date
    Apr 2003
    Location
    I AM CANADIAN!
    Age
    29
    Posts
    3,008
    cool.

    Smith is a bag of douche,FACT.

  3. Games   -   #3
    suprafreak6's Avatar Suprafreak6 is Back!
    Join Date
    Apr 2005
    Location
    -=U.S.A=-
    Posts
    2,450
    yeah read this about 2 hours ago, i was going to write about it, but go to torrentspy if you want gta lcs...if you search GTA liberty city... you see a torrent that currently has 3000leechers and like 6 seeders...how convieneint...ill take this when those leechers seed...(dought they will though) my posts on here have become really sloppy i believe...

  4. Games   -   #4
    silent h3ro's Avatar Poster BT Rep: +9BT Rep +9
    Join Date
    Nov 2003
    Location
    Detroit
    Age
    27
    Posts
    4,461
    Yep I read this on PSP updates... I check that site daily haha. I just need to buy my 2 gig stick or wait for the 4 gig ones and I'm def. downgrading to 1.5 and dling this.

  5. Games   -   #5
    Rip The Jacker's Avatar Retired
    Join Date
    Nov 2002
    Location
    Los Angeles, CA
    Age
    31
    Posts
    6,435
    Damn I wanted to make a thread about this, you beat me to it.

    I still can't believe this happened. We 1.5 users were waiting for this for a looong time, and it's here. I've been playing GTA on my 1.5 PSP for hours now... and what's more... I also got Megaman Maverick Hunter X to run on my 1.5 PSP with MPH's loader.

    All the people who upgraded to play Megaman are going to be sooo pissed. MPH has done some amazing work!

  6. Games   -   #6
    suprafreak6's Avatar Suprafreak6 is Back!
    Join Date
    Apr 2005
    Location
    -=U.S.A=-
    Posts
    2,450
    im the same as rip the jacker, i got both gta and megaman working along with crashteam racing

  7. Games   -   #7
    Spicker's Avatar AKA jaigandhi5 BT Rep: +7BT Rep +7
    Join Date
    Dec 2002
    Location
    Canada
    Posts
    3,484
    Quote Originally Posted by Rip The Jacker
    Damn I wanted to make a thread about this, you beat me to it.

    I still can't believe this happened. We 1.5 users were waiting for this for a looong time, and it's here. I've been playing GTA on my 1.5 PSP for hours now... and what's more... I also got Megaman Maverick Hunter X to run on my 1.5 PSP with MPH's loader.

    All the people who upgraded to play Megaman are going to be sooo pissed. MPH has done some amazing work!
    This new version like the previous version lets you play UMD games that require 2.0 + firmware on 1.50. There is a catch however, you need to have an iso of the same game in order for the loader to work.

    The new version lets you play games for more than 10 min. The previous version seized after exactly 10 minutes, so for the MPH loader users, this is a great update to the loader. The previous version was "demo" release eventhough some people thought it was the real thing, but realized that it only worked for 10 min.


    Looks like its time to bust out the old psp

    havent touched the dam thing in months..

    My Blog
    I'm still here.

  8. Games   -   #8
    Rip The Jacker's Avatar Retired
    Join Date
    Nov 2002
    Location
    Los Angeles, CA
    Age
    31
    Posts
    6,435
    Quote Originally Posted by Spicker
    The new version lets you play games for more than 10 min. The previous version seized after exactly 10 minutes, so for the MPH loader users, this is a great update to the loader. The previous version was "demo" release eventhough some people thought it was the real thing, but realized that it only worked for 10 min.
    Meh, the same day MPH released the "demo" version, about 2 hours later a bunch of people posted patches for it removing the 10 min limit. I had the loader without the 10 min limit the first day the "demo" was released.

    GTA rocks!!!

  9. Games   -   #9
    suprafreak6's Avatar Suprafreak6 is Back!
    Join Date
    Apr 2005
    Location
    -=U.S.A=-
    Posts
    2,450
    i need a 1 gig memory stick....

  10. Games   -   #10
    Rip The Jacker's Avatar Retired
    Join Date
    Nov 2002
    Location
    Los Angeles, CA
    Age
    31
    Posts
    6,435
    I have a 1GB memory stick, trust me, it's way too small!

    God I wish I had like a 10GB memory stick. That'd be sweet.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •