Your Ad Here Your Ad Here
Results 1 to 5 of 5

Thread: Civilization 4

  1. #1
    Duffman's Avatar Poster
    Join Date
    Jul 2003
    Age
    29
    Posts
    1,130
    I'm trying to play a little civ 4 here, but it keeps freezing and crashing. It mostly freezes, sometimes I get a bsod, but its just a blank blue screen.

    I'm running:
    AMD 2500+
    Abit NF7-s2
    Ati 9800 Pro
    1024 megs memory

    I tried updating my motherboard drivers, the ati catalyst drivers, I removed those, switched to omega ones, nothing works. At first I thought it was over heating, and the card was hot, but I took care of that. I did a little stress test with ati tool and no artifacts or crashing, cards not oc'ed. Im stumped.
    ...

  2. Software & Hardware   -   #2
    Virtualbody1234's Avatar Forum Star BT Rep: +2
    Join Date
    Oct 2003
    Location
    Canada
    Posts
    11,497
    Do you have all the latest patches installed? http://www.firaxis.com/support/suppo...meid=6&patch=1

    Maybe further help here: http://www.firaxis.com/support/suppo...gameid=6&cat=5

  3. Software & Hardware   -   #3
    Duffman's Avatar Poster
    Join Date
    Jul 2003
    Age
    29
    Posts
    1,130
    yeah I got the patches, ill take a look at that site though.
    ...

  4. Software & Hardware   -   #4
    Duffman's Avatar Poster
    Join Date
    Jul 2003
    Age
    29
    Posts
    1,130
    I got 2 BSOD's, on for nvmcp.sys, and kmixer.sys, I reinstalled my audio drivers, and now all I have is kmixer, and constant crashing
    ...

  5. Software & Hardware   -   #5
    can some1 please post civ 4 is want the game!!!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •