Your Ad Here Your Ad Here
Results 1 to 3 of 3

Thread: logitech x 230 Problem.

  1. #1
    LilAznAccommodator's Avatar Celestial Seraph
    Join Date
    Oct 2003
    Location
    California
    Age
    29
    Posts
    475
    Dear Readers,

    I just replaced my Speakers with these AND there seems to be a HUGE problem and I ran out of patience to return it for another (As I waited well over a week ><) but it seems that a 'piece' in the subwoofer is loose and just movign aroudn freely inside which just isnt' right... At first i thought it was the 'speaker' that goes to the hole in the front.. but then not sure.. and it is I think the same problem as this users comment:

    'Cons: The cardboard tube that forms the inner part of the port separated from the front of the port in shipping because glue was applied to the edge of the joint rather than the joint itself. Minus 1 egg. Appalling customer support from Logitech. No 800 number, I had to pay to be kept on hold for 20 minutes and still didn't get to talk to anyone. Minus 3 more eggs.'

    So I was wondering if there is anyway I could 'fix' this problem as I am not sure how to 'open' the subwoofer, there are 2 screw thingy at the bottom but I don't think that would allow me to open it...

    After testing it out.. Yeah it seems that is what should be giving the BASS.. as even when I turn it at MAX.. there doesn't seem to be any Bass at all...
    EDIT: Okay unless I turn the Volume up really loud then there is some Bass present, otherwise at low/mid volume, there seems to be no vibration at all.

    2nd Edit: Here are some pictures (Not great as I can only view through the air hole.
    This one if a side view(Bass speaker is on the ground)


    Then this is the SubWoofer standing upright with the bass speaker facing right


    Hope that helps a little ><



    EDIT: Alright I am not sure how to open this subwoofer to fix it... as it seems something is attached to the Back Panal when I unscrew everything...
    Last edited by LilAznAccommodator; 01-18-2007 at 05:37 AM.

  2. Software & Hardware   -   #2
    popwar's Avatar Popwar
    Join Date
    Sep 2006
    Location
    Ohio
    Age
    29
    Posts
    232
    i have the same speakers. im blown away by the output. these are really good speakers and the bass shakes my house , but i dont know whats with your problem dude lol sorry, just take em back. i got mine from best buy and bought this 8 year replacement warranty for like 8 dollars.

  3. Software & Hardware   -   #3
    LilAznAccommodator's Avatar Celestial Seraph
    Join Date
    Oct 2003
    Location
    California
    Age
    29
    Posts
    475
    Hehe well let's just say the Port Tube is was makes the Bass go Boom Boom haha and since it is detached you don't feel anything because all the air comes out of that hole.. And I don't necessarily want ot RMA it back to NewEgg because sadly I might yet get another defective item so I am waiting for Customer Support (ONline) from Logitech to see what I can do as I can't call them due to calling fees so I have to wait till night when Dad gets home to use his phone.

    And yeah in the beginning I was planning to just buy them retail(BestBuy) but my friend was able to find them cheap online so I went with that.. Seems it was a bad move.. So yeah... Now I just awaiting for either a reply from Logitech/ Dad to come home to call them up to see what I can do.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •