Your Ad Here Your Ad Here
Results 1 to 7 of 7

Thread: Autorun.inf Won't Work :(

  1. #1
    I downloaded the Portable Apps collection off of and extracted it onto my flash drive. so ... it has a (hidden) autorun.inf file that is supposed to, well.. autorun the executable in PortableApps\PortableAppsMenu\PortableAppsMenu.exe.

    In Autorun.inf:
    The label works, the icon works, but when i double-click on the drive - it doesn't autorun the program. i would really like it to do that

  2. Software & Hardware   -   #2
    zapjb's Avatar Computer Abuser BT Rep: +3
    Join Date
    Nov 2002
    What OS?

  3. Software & Hardware   -   #3
    Your icon file is wrong, needs to be a .ico file, this example below works:

    Label=Label Here
    Then place the Autorun.inf in the main area of the exe file along with the ico file and your done.
    Other software Created by myself:
    Torrent Database
    Uninstaller 2007
    Rapidshare Proxy

  4. Software & Hardware   -   #4
    jf3000 actually my icon works fine with the .exe extension. autorun.inf just reads the icon of the executable.
    now i put the executable (PortableAppsMenu.exe) in the root directory, along with my auto run, and change it to
    Without success.

    Maybe I need to fix my registry? I do have a registry cleaner

  5. Software & Hardware   -   #5
    If a autorun isnt finctioning its usually due to the path or the files missing, hence doesnt load.
    Other software Created by myself:
    Torrent Database
    Uninstaller 2007
    Rapidshare Proxy

  6. Software & Hardware   -   #6
    game1283's Avatar "ǝuo ǝɥʇ" BT Rep: +7BT Rep +7
    Join Date
    May 2007
    I live in my own world!
    I don't know all kinds of flash drive, but usually some flash drive doesn't allow automated running of files, like what a CD does, so if you put an inf file there, it would run automatically only if you click the autorun, but registry modification can fix it, as well as some other flash now allows them..

  7. Software & Hardware   -   #7
    lynx's Avatar .
    Join Date
    Sep 2002
    Yorkshire, England
    Here's a document which explains what's going on:

    You need to add the following line: "UseAutoPlay=1"
    Also, look at the bit about content sniffing.

    Anything deeper than 4 folders deep won't be detected, and consequently won't trigger the autoplay function. One or more playable media files (even a simple bmp or ico file) less than 5 layers deep will cause the autoplay function to take over, rather than the desired autorun.

    Btw, it is better to use the ShellExecute command rather than the Open command if the software will crash on Windows 9x, since the ShellExecute command isn't recognised on 9x. It also gives you the opportunity of launching the default application for non-executable files. For example, "Open=anything.html" will be ignored, "ShellExecute=anything.html" will launch the default browser to display the html file.
    Last edited by lynx; 08-19-2007 at 10:42 AM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts