Ok so anyway I just bought myself a decent box running CentOS 5 and i've had a bit of a problem installing the basics.

xterm and vncserver both installed perfectly fine but when I tried to install wine (as root) I ended up with the following

Loading "installonlyn" plugin
Loading "protectbase" plugin
Setting up Install Process
Setting up repositories
kbs-CentOS-Extras         100% |=========================|  951 B    00:00
base                      100% |=========================| 1.1 kB    00:00
updates                   100% |=========================|  951 B    00:00
addons                    100% |=========================|  951 B    00:00
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
0 packages excluded due to repository protections
Parsing package install arguments
Nothing to do
And basically, nothing installs

I've tried everything, (yes I manually added the necessary .repo for CentOS in etc/yum.repos.d) so does ANYONE know what to do?!?!?

Also i'm somewhat new to linux and the shell so make it simple