Your Ad Here Your Ad Here
Results 1 to 2 of 2

Thread: Problem with setting up Setup the FTP Server (VSFTPD) CentOS

  1. #1
    clouseau66's Avatar Member
    Join Date
    Oct 2008
    Age
    48
    Posts
    6
    I have a problem on my server I'm sure it is something simple but I'll be damned if I can figure it out...In this section of the NAQ Guide for seedboxes:

    7. Setup the FTP Server (VSFTPD)
    You can setup a FTP Server on your seedbox to transfer files to and from your home PC. This is quite advantageous since you most likely will be able to download files from your server to your PC at the maximum speed provided by your ISP, as well as reducing the need to use Bittorrent at home.

    We had already installed VSFTPD from Section 3. Configuring VSFTPD is simple, however we also want to configure VSFTPD to use TLS/SSH authentication.

    Note: Enabling TLS/SSH authentication will NOT work if SELinux is enabled. See Section 2 to check if SELinux is enabled. And if so, to disable it.

    Note: Users will NOT be able to login if SELinux is enabled. See Section 2 to check if SELinux is enabled, and if so, to disable it.

    Note: The root user is not allowed to login with FTP by default.

    In VNC Desktop:

    We need root privileges to configure VSFTPD. The command "su" will let us switch user. Type in xterm (remember not to use the one that's running uTorrent):
    Code:
    $ su
    Password:
    #
    ***After I type in su it tell me this:
    bash: /bin/su: Permission denied!

    I'm not using the xterm that is running utorrent either, I need permission to do what I need to do. Any help on telling me how to resolves this would be highly appreciated!

    Thanks

    regards
    clouseau66

  2. Software & Hardware   -   #2
    clouseau66's Avatar Member
    Join Date
    Oct 2008
    Age
    48
    Posts
    6
    Fixed it no worries!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •