Your Ad Here Your Ad Here
Results 1 to 5 of 5

Thread: vsftpd settings

  1. #1
    I am having trouble setting up the vsftpd server on ubuntu desktop 8.04.
    I have followed naq's guide but everyime i try to connect to it it says connection refused.
    here are my settings in the vsftpd.conf


    rsa_private_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
    ssl_enable=YES
    force_local_logons_ssl=YES
    ssl_tlsv1=YES
    ssl_sslv2=YES
    ssl_sslv3=YES
    rsa_cert_file=/root/vsftpd.pem
    listen_port=54321
    pasv_min_port=54323
    pasv_max_port=54340

    I have followed the guide to open the ports also so i'm not sure what is wrong

    When i edit the file and try to restart vsftpd it says this

    Stopping FTP server: vsftpd No /usr/sbin/vsftpd found running; none killed.
    [ OK ]
    * Starting FTP server: vsftpd [ OK ]
    Last edited by cow800; 02-19-2009 at 04:06 PM.

  2. BitTorrent   -   #2
    something must be wrong in the config file as it is not starting. you may try to remove some settings, to see which one causes this.

  3. BitTorrent   -   #3
    Check your /etc/ftpusers file and make sure that the user you are trying to login with is not prohibited. Also check the chroot_list option in your config file. If you have it enabled the file MUST exist (even if blank). Use a ftp client that shows logs and post the logs here if that still doesn't work

  4. BitTorrent   -   #4
    Here are my settings in vsftpd.conf that are enabled ( the options without #in front?)

    # Run standalone? vsftpd can run either from an inetd or as a standalone
    # daemon started from an initscript.
    listen=YES

    Allow anonymous FTP? (Beware - allowed by default if you comment this out).
    anonymous_enable=NO
    # Uncomment this to allow local users to log in.
    local_enable=YES
    # Uncomment this to enable any form of FTP write command.
    write_enable=YES
    # go into a certain directory.
    dirmessage_enable=YES
    # Activate logging of uploads/downloads.
    xferlog_enable=YES
    # Make sure PORT transfer connections originate from port 20 (ftp-data).
    connect_from_port_20=YES

    at the end i added

    ssl_enable=YES
    force_local_logons_ssl=YES
    ssl_tlsv1=YES
    ssl_sslv2=YES
    ssl_sslv3=YES
    rsa_cert_file=/etc/ssl/certs/vsftpd.pem
    listen_port=54321
    pasv_min_port=54323
    pasv_max_port=54340

    I looked at my users file and my user name isn't there, but i saw a entry for daemon , is that anything to do with vsftpd?

    When i try to connect to the ftp using cuteftp pro i get this error The connection failed due to an error or timeout.
    I have tried all the different ssl settings to connect so i think its a problem with the vsftpd settings.
    Also i don't have access to root account.

  5. BitTorrent   -   #5
    lee551's Avatar no soup for you! BT Rep: +5
    Join Date
    Jan 2004
    Posts
    1,867
    make sure in cuteftp that you're connecting by "SFTP using SSH2 (secure shell)."

    i'm not sure if this was the default connection, but i think i had to change it from standard FTP.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •