Results 1 to 2 of 2

Thread: Upload Speeds; Tweakin Em.

  1. #1
    Alright. New to these boards, and from what I've seen, this has never been posted before.

    So here's my story, and my tip.

    I noticed the other day that my uploads were slow.
    Very slow.
    Unsure why, since I have a very good DSL connection, I decided it must be an options issue.
    Well, I was right.
    My max bandwidth for uploads was 64 kbits.
    That's 8 kB/s.
    And since 3 people were downloading, that accounts for the horrible 2.67kB/s they were getting.
    Since I want to be a USEFUL source for filesharing, I upped this 64 kbits to 256kbits.
    That translates into a max upload speed of 32 kB/sec which is not my entire upload bandwidth, so I can still do other things requiring timely upload, but is enough that people can get at least 10kB/s from me.

    Now, here's the instructions for those who have the same "problem" as I did.

    Click 'Options' menu in Kazaa (of course)
    Select 'Kazaa Lite K++ options. A new screen will come up.
    Choose the 'Advanced' tab
    The second editable box from the top contains your max allocated upload bandwidth. Enter whichever number you desire in here. REMEMBER that the number in that box divided by 8 = the actual kB/s transfer speed your allocating.

    Please increase this number. I've been having trouble downloading anything from anyone at speeds greater than about 5kB/s, which is really time consuming.

    (Hm, cept this one guy who I was downloading at 100kB/s from. I only wish he had better music.)

    Well, I hope this helps at least 1 person.
    Happy sharing!

  2. File Sharing   -   #2
    Join Date
    Sep 2002
    What's your DSL's connection max bandwidth ratings according to your ISP and online tests?
    Naturally, it's mainly upload bandwidth that you're interested in knowing for tweaking uploads...

    Many DSL lines have some of their signal frequency range which is EITHER upload or download bandwidth -- so if you set uploads high, downloads suffer even though upload max hasn't been reached.

    Also, TCP/IP packet overheads are NON-TRIVIAL! 8 bits may make 1 byte, but it takes more like 9-12 bits to transmit every data byte. Each packet has to have headers saying what ip + port it's from, what ip + port it's going to, TCP specification type, Time-To-Live, possibly a timestamp, and a few other things. At minimum, I think that's 32 bytes per every packet. So it helps to make EACH packet as large as possible so you have to pay this overhead LESS per every KB of data you send out. It is commonly set to only 576 bytes by default. I set my MTU (which is max packet size) to 1,500 Bytes -- which is standard maximum for cablemodems, T-1's, and ethernet lines.

    I used TCP/IP Optimizer from to do this.

    TCP/IP Optimizer also sets network buffers -- which making them somewhat larger (I use the extreme setting for max size) allows slightly better transmit/receive rates, but eats more ram PER connection -- like up to 1/2 MB per connection, because EACH one gets its own buffer! I reduced the max connections PER webpage from the changed settings of 20 and 40 down to only 2 and 4 -- but that's because I'm on Win 98SE.

    My cablemodem is rated for 1.5 mbps down and 0.25 mbps up. So in theory I have a max upload bandwidth of 256 kilobits/sec. However in practice due to TCP/IP overheads and parity bits, I cannot get uploads in KL++ to go any faster than they do when I set KL++ max upload bandwidth limits to 232 kilobits/sec.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts