Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Replacing Dlls

  1. #1

    Anyone know what is the best way to replace a dll called - comdlg32.dll

    Its used by windows constantly, and i need to find a way to replace it.. as my 'save as'.. boxes error on me and crash programs beacause of an error in the used dll..

    Thanks guys!

    EDIT - i already have the file and the 'ocx file' from

  2. Software & Hardware   -   #2
    Join Date
    May 2003
    download it to your desktop, remove the old one then place the new one it the proper folder

  3. Software & Hardware   -   #3
    Join Date
    Mar 2003
    Didn't you get a short command with it? I can't remember it exactly but it contains "reg.ocx" or something. If the old one is fully gone from the system, no restore points or cached copies, then windows may automatically pick up the new one anyway.

    Something like this maybe...

  4. Software & Hardware   -   #4
    Join Date
    Mar 2003
    If its the dialogue dll mate i dont think you need to register it.Just place it in the windows system/system32 folder

    Otherwise mate to register it go to the run>start and and type "regsvr32 filename".

  5. Software & Hardware   -   #5
    i can't delete, rename or edit the existing one in system32.... it won't let me cause its being used..

    i think i found out how to do it by using command prompt... but i'm gonna try it out now..

    The one in my system32 folder is damaged somehow.. don't ask... anyway, i've already tried registering it with the command in run.. it never worked.

    Yes it did come with a .ocx, i may have to replace that file too

  6. Software & Hardware   -   #6

    Reboot in safe mode (f8) and then replace.

  7. Software & Hardware   -   #7
    ok just done it... tried it out... the save as.. does nothing... hmm.... so i realise i need to register the new files... went to do that.. run...... ocx one worked ok... the dll one gave this Error message:

    " RegSvr32

    comdlg32.dll was loaded, but the DllRegisterServer entry point was not found.

    This file can not be registered. "


  8. Software & Hardware   -   #8

  9. Software & Hardware   -   #9
    I take it you tried the command:- regsvr32 comdlg32.dll ?

    It may be that the dll's are searching for other files that are not available.

  10. Software & Hardware   -   #10
    yep.. thats what i did..

    I don't know whatelse to do?

Page 1 of 2 12 LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts