Your Ad Here Your Ad Here
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Internet Problem

  1. #1
    I am running Red Hat Linux 9 and have an intel 536ep modem.

    I have downloaded and installed the drivers OK then used KPPP to set up the net connection

    When I connect themodem dials and appears to connect OK but i cannot access any web sites.

    any help would be appreciated
    There are 10 types of people in the world those who understand binary and those who dont

  2. Software & Hardware   -   #2
    Poster
    Join Date
    Jan 2003
    Posts
    908
    check your iptables to see that http isnt blocked

    try some other protocols just to test it out and see if it is really connected

  3. Software & Hardware   -   #3
    shn's Avatar 3μ|\|(7
    Join Date
    May 2003
    Posts
    3,585
    Originally posted by ObiWan@12 February 2004 - 17:08
    I am running Red Hat Linux 9 and have an intel 536ep modem.

    I have downloaded and installed the drivers OK then used KPPP to set up the net connection

    When I connect themodem dials and appears to connect OK but i cannot access any web sites.

    any help would be appreciated
    What provider are you using to connect?

  4. Software & Hardware   -   #4
    check your iptables to see that http isnt blocked
    how would i do that

    PS i ran ifconfig and i have been given an IP address
    There are 10 types of people in the world those who understand binary and those who dont

  5. Software & Hardware   -   #5
    4play's Avatar knob jockey
    Join Date
    Jan 2003
    Location
    London
    Age
    35
    Posts
    5,530
    im guessing you have to set the nameservers for your isp.

    try pinging 216.239.39.99 which is google. if you get packets returned your connection is up

    then try to ping google.com if this does not work its nameservers.

    there is an option in kppp somewhere to add your own. just look up 2 of you isps.

  6. Software & Hardware   -   #6
    i tried pinging google.com and it times out, ill try the IP address later

    i'm with BT Openworld
    There are 10 types of people in the world those who understand binary and those who dont

  7. Software & Hardware   -   #7
    Poster
    Join Date
    Jan 2003
    Posts
    908
    Originally posted by ObiWan@12 February 2004 - 17:14
    check your iptables to see that http isnt blocked
    how would i do that

    PS i ran ifconfig and i have been given an IP address
    i use a frontend for it because configuring a firewall from command line seems tedious and the frontend i use bundles a lot of commonly used protocols in so you just check or uncheck them

    you can add your own too of couse

    http://www.simonzone.com/software/guarddog/

    there are many frontends to iptables, look around and see what you like

    but try 4play's suggestion first, that sounds more sensible than http being blocked

  8. Software & Hardware   -   #8
    4play's Avatar knob jockey
    Join Date
    Jan 2003
    Location
    London
    Age
    35
    Posts
    5,530
    i had the same problem when i first used my 56k modem and i used bt openworld as well.

    try using a few of these dns servers.

  9. Software & Hardware   -   #9
    I'll try that and let you you know how i get on

    DAMN it's a pain in the arse having to reboot into windows to get access to the net
    There are 10 types of people in the world those who understand binary and those who dont

  10. Software & Hardware   -   #10
    shn's Avatar 3μ|\|(7
    Join Date
    May 2003
    Posts
    3,585
    Originally posted by ObiWan@12 February 2004 - 17:27
    I'll try that and let you you know how i get on

    DAMN it's a pain in the arse having to reboot into windows to get access to the net
    Are you even initializing the modem at all. What I mean is, can you hear it trying to dial out? If not then you probably need a 56k generic modem driver so that your modem can initialize.

    Theese chipsets are generally the most common for typical 56k conexant modems. Although it may not be as common where you live, in the U.S. a lot of computers that come with 56k modems use theese chipsets so see if yours is one.

    http://www.linuxant.com/drivers/?PHPSESSID...b16a3b88d16d969

    If so then just install the driver for your distro and follow the instructions.

    In any other instance I would say try modprobing /dev/modem or:

    "modprobe /dev/ttyS0" from a terminal and without the quotes

    /dev/modem is only a symbolic link from your original hardware modem device but a lot of times the kernels are not not compiled with that symbolic link, although your ppp configuration may say your modem is on that device. In reality it may be on:
    /dev/ttyS0 is so then just link it symbolically yourself like this:

    ln -sf /dev/ttyS0 /dev/modem

    Then edit your /etc/ppp/?? config file in accordance with the info above, but if it says /dev/modem in the config files then probably leave it since you would have linked the actual serial device to /dev/modem anyway using the method above.

    Hope that helped.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •