Your Ad Here Your Ad Here
Results 1 to 7 of 7

Thread: Buffer-overrun Vulnerability In Ws Ftp Pro

  1. #1
    Buffer-overrun vulnerability in WS_FTP Pro or ( get Filezilla cause its better )


    John Layman discovered that a buffer-overrun vulnerability in WS_FTP Pro 8.02 and earlier can cause arbitrary code execution on the vulnerable system. If an attacker sends an ASCII mode directory data file that exceeds 260 bytes, and the file isn't terminated by a carriage return/line feed (CRLF), a buffer overrun results. WS_FTP Pro 8.03 isn't vulnerable to the buffer-overrun condition, so users should consider upgrading to version 8.03.
    SOURCE

  2. Software & Hardware   -   #2
    SH thanks for the info and the heads up. I updated the software and I also downloaded FileZilla, that program is TIGHT. I see myself switch over as soon as I get all my ftp sites configured in FileZilla

  3. Software & Hardware   -   #3
    shn's Avatar 3μ|\|(7
    Join Date
    May 2003
    Posts
    3,585
    Interesting.

    This is not their 1st flaw.

  4. Software & Hardware   -   #4
    BANNED
    Join Date
    Mar 2003
    Posts
    4,053
    hi shn

    i hope u enjoy'd had a good one.

    I tried sayin' earlier everything post i try today i'm gettin anti spam crap.So fuck it.

  5. Software & Hardware   -   #5
    Poster
    Join Date
    Oct 2003
    Location
    Montevideo,Uruguay
    Posts
    989
    well that migh explain somethings .
    but anyways i updated long ago...

  6. Software & Hardware   -   #6
    h1
    Guest
    Buffer overflows are the first thing they teach you in a programming class.

    And get LeechFTP, it owns FileZilla.

  7. Software & Hardware   -   #7
    Poster
    Join Date
    Oct 2003
    Location
    Montevideo,Uruguay
    Posts
    989
    i never got a programming class,all i learned was purely from mysqelf (and with google)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •