Your Ad Here Your Ad Here
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Installing phpBB - Problem's

  1. #1
    Samurai's Avatar Usenet Fanboy
    Join Date
    May 2003
    Location
    London, United Kingdom
    Age
    35
    Posts
    4,532

    Tongue

    I ran into this a while back when I first came to use phpBB and I remember it driving me crazy back then. I did manage to fix the problem but until now, I never needed to install another forum...

    Basically I've created a database in mysql, called 'forum'. This means that my forums will be located at http://www.mysite.com/forum/ - so far so good.

    I then created a user to access this database, which, again went well. The user name is 'samurai' with all permissions set.

    Next was the installation of phpBB. A folder was created called 'forum' in the correct place and phpBB was installed into it via ftp.

    I can access every file fine via ftp.

    Now when I go to install the forums using the built in phpBB installer, this is where the shit hits the fan...

    Here's the screenshots:







    As you can see I've put the correct info in the right fields but I'm still getting these errors no matter what I change or alter.

    Does anyone know how to fix this?

    I know there's not a problem with the installation or any of the files so it's not that.

    Help
    Last edited by Samurai; 01-23-2005 at 03:04 PM.

  2. Internet, Programming and Graphics   -   #2
    Samurai's Avatar Usenet Fanboy
    Join Date
    May 2003
    Location
    London, United Kingdom
    Age
    35
    Posts
    4,532
    Alright I know there's people in here that uses phpBB so stop hiding this is important

  3. Internet, Programming and Graphics   -   #3
    Illuminati's Avatar Simple Bystander BT Rep: +7BT Rep +7
    Join Date
    May 2003
    Location
    2008 European Capital of Culture
    Age
    32
    Posts
    2,758
    The green covered areas in the first screenie is your account name, right?

    You need to include that bit at the start in the database name & username. e.g. if my account was "ill", cPanel would add "ill_" to database name & username. Hence, I'd put in "ill_database" and "ill_username" in the relevant areas.

    Just a case of putting it in exactly as it says - Hope that helps
    Last edited by Illuminati; 01-23-2005 at 04:08 PM.

  4. Internet, Programming and Graphics   -   #4
    Samurai's Avatar Usenet Fanboy
    Join Date
    May 2003
    Location
    London, United Kingdom
    Age
    35
    Posts
    4,532
    yes i've tried that and it didn't work

    i've tried all sorts of ways. it's definatly the 'database configuration' but i just don't know what it could be.

    i've tried xxx_samurai, samurai_xxx, xxx, samurai

    also tried forum_xxx, xxx_forum, forum

    that didn't work either

  5. Internet, Programming and Graphics   -   #5
    Illuminati's Avatar Simple Bystander BT Rep: +7BT Rep +7
    Join Date
    May 2003
    Location
    2008 European Capital of Culture
    Age
    32
    Posts
    2,758
    Server - localhost
    Database Name - xxx_forum
    Database Username - xxx_samurai
    Database Password - (whatever password you chose)
    Prefix for tables - (Don't touch)

    Try them exactly (substituting the xxx for your account of course) and post the errors you get if any

  6. Internet, Programming and Graphics   -   #6
    Samurai's Avatar Usenet Fanboy
    Join Date
    May 2003
    Location
    London, United Kingdom
    Age
    35
    Posts
    4,532
    Warning: mysql_connect(): Access denied for user: 'xxx_samurai@localhost' (Using password: YES) in /home/xxx/public_html/forum/db/mysql4.php on line 48

    Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in /home/xxx/public_html/forum/db/mysql4.php on line 330

    Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in /home/xxx/public_html/forum/db/mysql4.php on line 331
    phpBB : Critical Error

    Could not connect to the database

    xxx = account. i would post it but it's a friend's account.

  7. Internet, Programming and Graphics   -   #7
    Samurai's Avatar Usenet Fanboy
    Join Date
    May 2003
    Location
    London, United Kingdom
    Age
    35
    Posts
    4,532
    Connection Strings
    Perl $dbh = DBI->connect("DBI:mysql:xxx_forum:localhost","xxx_samurai","<PASSWORD HERE>");
    PHP $dbh=mysql_connect ("localhost", "xxx_samurai", "<PASSWORD HERE>") or die ('I cannot connect to the database because: ' . mysql_error());
    mysql_select_db ("xxx_forum");
    Aarrrrgh!!! Connection strings are exactly how my installation settings are and is still refusing me access.

    I'm running out of ideas

  8. Internet, Programming and Graphics   -   #8
    try:
    mysql_select_db ("xxx_forum", $dbh);
    Last edited by ObiWan; 01-23-2005 at 08:17 PM.
    There are 10 types of people in the world those who understand binary and those who dont

  9. Internet, Programming and Graphics   -   #9
    Formula1's Avatar Poster
    Join Date
    Sep 2003
    Location
    USA
    Posts
    3,786
    are you sure you put XXX_forum as your database name during installation of phpbb ? not just forum ?

  10. Internet, Programming and Graphics   -   #10
    SuperScript's Avatar User Title...What?
    Join Date
    Nov 2004
    Location
    Canada
    Posts
    84
    Quote Originally Posted by Illuminati
    The green covered areas in the first screenie is your account name, right?

    You need to include that bit at the start in the database name & username. e.g. if my account was "ill", cPanel would add "ill_" to database name & username. Hence, I'd put in "ill_database" and "ill_username" in the relevant areas.

    Just a case of putting it in exactly as it says - Hope that helps
    This is correct and it should work.

    Are you incorrectly typing in your DB password?
    Formerly [Spam]

    Join My Forums: JAB - Just Another Board - http://www.justanotherboard.tk/

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •